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	Version/Release Number
	<Version/Release Number>
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<Provide information on how the development and distribution of the Test Report is controlled and tracked. Use the table below to provide the version number, date, author, and a brief description of the reason for creating the revised version.>
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Note to the Author
[This document is a template of a Test Report document for a project. The template includes instructions to the author, boilerplate text, and fields that should be replaced with the values specific to the project.

· Blue italicized text enclosed in square brackets ([text]) provides instructions to the document author, or describes the intent, assumptions and context for content included in this document.
· Blue italicized text enclosed in angle brackets (<text>) indicates a field that should be replaced with information specific to a particular project.
· Text and tables in black are provided as boilerplate examples of wording and formats that may be used or modified as appropriate to a specific project.  These are offered only as suggestions to assist in developing project documents; they are not mandatory formats.

When using this template for your project document, it is recommended that you follow these steps:
1. Replace all text enclosed in angle brackets (e.g., <Project Name>) with the correct field values. These angle brackets appear in both the body of the document and in headers and footers.  To customize fields in Microsoft Word (which display a gray background when selected):
a. Select File>Properties>Summary and fill in the Title field with the Document Name and the Subject field with the Project Name.  
b. Select File>Properties>Custom and fill in the Last Modified, Status, and Version fields with the appropriate information for this document. 
c. After you click OK to close the dialog box, update the fields throughout the document with these values by selecting Edit>Select All (or Ctrl-A) and pressing F9.  Alternatively, you can update an individual field by clicking on it and pressing F9. This must be done separately for Headers and Footers.
2. Modify boilerplate text as appropriate to the specific project. 
3. To add any new sections to the document, ensure that the appropriate header and body text styles are maintained.  Styles used for the Section Headings are Heading 1, Heading 2 and Heading 3.  Style used for boilerplate text is Body Text.
4. To update the Table of Contents, right-click and select “Update field” and choose the option- “Update entire table”
5. Before submission of the first draft of this document, delete this “Notes to the Author” page and all instructions to the author, which appear throughout the document as blue italicized text enclosed in square brackets.]
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NOTE: If project teams are using automated tools to track and document testing activities, it is acceptable to substitute tool-generated test result reports if they meet the information requirements of the PPM template.
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[bookmark: _Toc292181763][bookmark: _Toc292181764][bookmark: _Toc292181765][bookmark: _Toc292181766][bookmark: _Toc292181781][bookmark: _Toc364331553][bookmark: _Toc364331696][bookmark: _Toc364331554][bookmark: _Toc364331697][bookmark: _Toc364331555][bookmark: _Toc364331698][bookmark: _Toc364331556][bookmark: _Toc364331699][bookmark: _Toc364331557][bookmark: _Toc364331700][bookmark: _Toc364678707][bookmark: _Toc364678747][bookmark: _Toc364331558][bookmark: _Toc364331701][bookmark: _Toc364678708][bookmark: _Toc364678748][bookmark: _Toc364331559][bookmark: _Toc364331702][bookmark: _Toc364678709][bookmark: _Toc364678749][bookmark: _Toc364331560][bookmark: _Toc364331703][bookmark: _Toc364678710][bookmark: _Toc364678750][bookmark: _Toc391926302][bookmark: _Toc237919290]Introduction
[bookmark: _Toc391926303][bookmark: _Toc105907880][bookmark: _Toc106079190][bookmark: _Toc106079515][bookmark: _Toc106079784][bookmark: _Toc107027560][bookmark: _Toc107027770]3.1 Purpose
This <Project Name> Test Report provides a summary of the results of test performed as outlined within this document.
[bookmark: _Toc391926304]Test Summary 
<Provide high-level measurements regarding the testing activities executed for the solution. If the project team uses a repository to track the status of test cases and defects, the table below may be replaced with information extracted from the repository.>
	Category
	Number of Test Cases
Planned
	Number of Test Cases
Executed
	Number of Test Cases Executed Successfully
	Number of Test Cases Executed Unsuccessfully
	Number of Resolved Defects
	Number of Fatal Defects
	Number of Major Defects
	Number of Minor Defects 

	
	
	
	
	
	
	
	
	

	
	
	
	
	
	
	
	
	

	
	
	
	
	
	
	
	
	

	Total
	
	
	
	
	
	
	
	


Table 1 - Sample Test Summary Report
Suggested Severity Legend:
Minor: A defect that will not cause a failure in execution of the product
Major: A defect that will cause an observable product failure or departure from requirements
Fatal: A defect that will cause the system to crash or close abruptly or affect other applications


[bookmark: _Toc391926305]Test Results
<Summarize the test results that were within the scope of the Test Plan. Include a detailed description of any deviations from the original test plan, design, test case, or expected results. Include any issues or bugs discovered during the test. If the project team uses a repository to track the status of test cases and defects, you may replace the tables below with information extracted from the repository.
If necessary, add other subsections to record the results of other categories of testing.>
[bookmark: _Toc280517205][bookmark: _Toc391926306]System/Integration Testing
Table 2 below summarizes the results of system/integration testing:
	Test Case ID
	Date Tested
	Tester
	Pass/Fail
	Severity of Defect
	Summary of Defect
	Comments
	Test Incident ID

	
	
	
	
	
	
	
	


[bookmark: _Ref295290671][bookmark: _Toc280517206]Table 2 - Sample System/Integration Testing Summary Report
[bookmark: _Toc391926307]User Acceptance Testing
Table 3 below summarizes the results of user acceptance testing:
	Test Case ID
	Date Tested
	Tester
	Pass/Fail
	Severity of Defect
	Summary of Defect
	Comments
	Test Incident ID

	
	
	
	
	
	
	
	


[bookmark: _Ref295290683][bookmark: _Toc280517207]Table 3 - Sample User Acceptance Testing Summary Report




[bookmark: _Toc391926308]Other Required Testing
Table 4 below summarizes the results of other required testing:
	Test Case ID
	Date Tested
	Tester
	Pass/Fail
	Severity of Defect
	Summary of Defect
	Comments
	Test Incident ID

	
	
	
	
	
	
	
	


Table 4 - Sample Other Required Testing Summary Report
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[bookmark: _Toc295130758][bookmark: _Toc295131703][bookmark: _Toc391926309]Variances
<Describe any variances between the planned testing and the actual testing. Also, provide an assessment of the manner in which the test environment may be different from the operational environment and the effect of this difference on the test results.>
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[bookmark: _Toc391926310]Summary of Defects
[bookmark: _Toc391926311]Open Defects
<If using a standard defect-tracking tool, use the tool to generate the defect log. Apply the definitions listed in the tool.  Include those definitions.>

	Project Name
	
	
	Severity
	
	Priority

	Test Lead
	
	
	1
	Urgent
	
	1
	Critical

	Tester Completing Form
	
	
	2
	High
	
	2
	High

	
	
	
	3
	Medium
	
	3
	Moderate

	
	
	
	4
	Low
	
	4
	Low



	Severity – Classification of defect (bug) to indicate the degree of negative impact on quality or the degree of impact that a defect has on the development or operation of a component or system.

	Urgent
	The defect affects critical functionality or critical data.  It does not have a workaround.  Example: Unsuccessful installation, complete failure of a feature

	High
	The defect affects major functionality or major data.  It has a workaround but is not obvious and is difficult. Example: A feature is not functional from one module but the task is doable if 10 complicated indirect steps are followed in another module(s)

	Medium
	The defect affects minor functionality or non-critical data.  It has an easy workaround.  Example: A minor feature that is not functional in one module but the same task is easily doable from another module

	Low
	The defect does not affect functionality or data.  It does not even need a workaround. It does not affect productivity or efficiency.  It is merely an inconvenience.  Example: Petty layout discrepancies, spelling/grammatical errors

	Priority – The level of business importance assigned to a defect.

	Critical
	This needs to be fixed right now; everything else can wait; the build cannot be released with the defect

	High
	Should be fixed as early as possible

	Moderate
	May be fixed after the release / in the next release

	Low
	Fixing can be deferred until all other priority defects are fixed


Table 5 – Definitions of Severity and Priority of Defect
	ID#
	Source
	Bug/Defect Description
	Severity
	Priority
	Resolution Strategy
	Associated Change Request 

	<Provide the associated test case ID number>
	<Identify the source of the problem by using the reference number from the Test Case Summary Report.>
	<Describe the bug/defect. Include error message generated, sequence of events that triggered it, etc.>
	<Refer to Severity/ Priority charts> 
	<Refer to Severity/ Priority charts>
	<Identify what steps need to be taken, and by whom, to resolve the identified problem>
	<If applicable, enter a change request number associated with correcting this bug/ defect>

	
	
	
	
	
	
	

	
	
	
	
	
	
	


Table 6 – Sample Summary of Open Defects 


[bookmark: _Toc280517211][bookmark: _Toc391926312]Closed Defects
<If using a standard defect-tracking tool, generate the defect log from the defect-tracking tool.  Apply the definitions listed in the tool.  Include those definitions.>
	Project Name
	
	
	Severity
	
	Priority

	Test Lead
	
	
	1
	Urgent
	
	1
	Critical

	Tester Completing Form
	
	
	2
	High
	
	2
	High

	
	
	
	3
	Medium
	
	3
	Moderate

	
	
	
	4
	Low
	
	4
	Low



	Severity – Classification of defect (bug) to indicate the degree of negative impact on quality or the degree of impact that a defect has on the development or operation of a component or system.

	Urgent
	The defect affects critical functionality or critical data.  It does not have a workaround.  Example: Unsuccessful installation, complete failure of a feature

	High
	The defect affects major functionality or major data.  It has a workaround but is not obvious and is difficult. Example: A feature is not functional from one module but the task is doable if 10 complicated indirect steps are followed in another module(s)

	Medium
	The defect affects minor functionality or non-critical data.  It has an easy workaround.  Example: A minor feature that is not functional in one module but the same task is easily doable from another module

	Low
	The defect does not affect functionality or data.  It does not even need a workaround. It does not affect productivity or efficiency.  It is merely an inconvenience.  Example: Petty layout discrepancies, spelling/grammatical errors

	Priority – The level of business importance assigned to a defect.

	Critical
	This needs to be fixed right now; everything else can wait; the build cannot be released with the defect

	High
	Should be fixed as early as possible

	Moderate
	May be fixed after the release / in the next release

	Low
	Fixing can be deferred until all other priority defects are fixed


Table 7 – Definitions of Severity and Priority of Defect




	ID#
	Source
	Bug/Defect Description
	Severity
	Priority
	Resolution Strategy
	Associated Change Request 
	Date Resolved

	<Provide the associated test case ID number>
	<Identify the source of the problem by using the reference number from the Test Case Summary Report.>
	<Describe the bug/defect. Include error message generated, sequence of events that triggered it, etc.>
	<Refer to Severity/ Priority charts> 
	<Refer to Severity/ Priority charts>
	<Identify what steps were taken, and by whom, to resolve the identified problem>
	<If applicable, enter a change request number associated with correcting this bug/ defect>
	<Enter the date when the issue was resolved>

	
	
	
	
	
	
	
	

	
	
	
	
	
	
	
	

	
	
	
	
	
	
	
	


Table 8 – Sample Summary of Closed Defects
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[bookmark: _Toc391926313]Recommendations
<Provide any recommended improvements in the design, operation, or future testing of the solution that resulted from the test activities. Provide a discussion of each recommendation and its impact on the business product. If there are no recommendations to report, simply state that fact.>


[bookmark: _Toc391926314]Appendix A: References
<Insert the name, version number, description, and physical location of any documents referenced in this document. Add rows to the table as necessary.>
Table 9 below summarizes the documents referenced in this document.
	Document Name
	Description
	Location

	<Document name and version number>
	<Document description>
	<URL to where document is located>

	
	
	

	
	
	


[bookmark: _Ref295215312][bookmark: _Ref295215302]Table 9- References


[bookmark: _Toc292181788][bookmark: _Toc292715832][bookmark: _Toc391926315]Appendix B: Key Terms
Table 10 below provides definitions and explanations for terms and acronyms relevant to the content presented within this document.
	Term
	Definition

	[Insert Term]
	<Provide definition of term and acronyms used in this document>

	
	

	
	


[bookmark: _Ref295215342]Table 10 - Key Terms
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